Commit 0837051c authored by Matija Obreza's avatar Matija Obreza
Browse files

Fail compilation on warnings and use of deprecated API

parent 76ab4ab9
......@@ -123,13 +123,14 @@
<plugin>
<inherited>true</inherited>
<artifactId>maven-compiler-plugin</artifactId>
<version>3.3</version>
<version>3.6.1</version>
<configuration>
<source>${jdk.source}</source>
<target>${jdk.target}</target>
<optimize>true</optimize>
<showDeprecation>true</showDeprecation>
<showWarnings>true</showWarnings>
<showDeprecation>true</showDeprecation>
<failOnWarning>true</failOnWarning>
</configuration>
</plugin>
<!--maven-surefire-plugin -->
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment