Commit 4278ff8f authored by Matija Obreza's avatar Matija Obreza
Browse files

Merge branch '44-upgrade-dependencies' into 'main'

Resolve "Upgrade dependencies"

Closes #44

See merge request genesys-pgr/application-blocks!95
parents 23771c8d 2907bb38
......@@ -93,13 +93,6 @@
<version>3.2-SNAPSHOT</version>
</dependency>
<dependency>
<groupId>org.apache.tomcat</groupId>
<artifactId>tomcat-jdbc</artifactId>
<version>7.0.107</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-aspects</artifactId>
......
......@@ -97,12 +97,6 @@
</build>
<dependencies>
<dependency>
<groupId>org.apache.tomcat</groupId>
<artifactId>tomcat-jdbc</artifactId>
<version>7.0.42</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
......
......@@ -32,21 +32,19 @@
<jdk.target>11</jdk.target>
<jdk.source>11</jdk.source>
<show.deprecations>false</show.deprecations>
<slf4j.version>1.7.30</slf4j.version>
<junit.version>4.13.1</junit.version>
<slf4j.version>1.7.31</slf4j.version>
<junit.version>4.13.2</junit.version>
<org.hamcrest.version>2.2</org.hamcrest.version>
<nexus-staging-maven-plugin.version>1.6.8</nexus-staging-maven-plugin.version>
<jackson.version>2.11.4</jackson.version>
<spring.version>5.2.12.RELEASE</spring.version>
<spring.data.version>2.3.6.RELEASE</spring.data.version>
<spring.security.oauth2.version>2.3.8.RELEASE</spring.security.oauth2.version>
<jackson.version>2.12.4</jackson.version>
<spring.version>5.3.9</spring.version>
<spring.data.version>2.5.3</spring.data.version>
<spring.security.oauth2.version>2.5.1.RELEASE</spring.security.oauth2.version>
<querydsl.version>4.4.0</querydsl.version>
<spring.security.version>5.3.6.RELEASE</spring.security.version>
<hibernate.version>5.4.27.Final</hibernate.version>
<hsqldb.version>2.5.1</hsqldb.version>
<tomcat-jdbc.version>8.5.8</tomcat-jdbc.version>
<spring.security.version>5.5.1</spring.security.version>
<hibernate.version>5.5.3.Final</hibernate.version>
<hsqldb.version>2.6.0</hsqldb.version>
<tomcat-jdbc.version>10.0.8</tomcat-jdbc.version>
</properties>
<repositories>
......@@ -76,7 +74,7 @@
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>flatten-maven-plugin</artifactId>
<version>1.0.1</version>
<version>1.2.7</version>
<configuration>
<flattenMode>ossrh</flattenMode>
</configuration>
......@@ -195,7 +193,7 @@
<dependency>
<groupId>org.apache.commons</groupId>
<artifactId>commons-lang3</artifactId>
<version>3.11</version>
<version>3.12.0</version>
<scope>provided</scope>
</dependency>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment