Commit 91054c88 authored by Matija Obreza's avatar Matija Obreza
Browse files

log4j: slf4j dependency as provided, log4j only needed in our testing

parent f2052058
...@@ -32,6 +32,7 @@ ...@@ -32,6 +32,7 @@
<jdk.target>11</jdk.target> <jdk.target>11</jdk.target>
<jdk.source>11</jdk.source> <jdk.source>11</jdk.source>
<show.deprecations>false</show.deprecations> <show.deprecations>false</show.deprecations>
<slf4j.version>1.7.31</slf4j.version>
<log4j2.version>2.16.0</log4j2.version> <log4j2.version>2.16.0</log4j2.version>
<junit.version>4.13.2</junit.version> <junit.version>4.13.2</junit.version>
<org.hamcrest.version>2.2</org.hamcrest.version> <org.hamcrest.version>2.2</org.hamcrest.version>
...@@ -163,18 +164,23 @@ ...@@ -163,18 +164,23 @@
</dependency> </dependency>
<!-- Logging dependencies --> <!-- Logging dependencies -->
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-api</artifactId>
<version>${slf4j.version}</version>
</dependency>
<dependency> <dependency>
<groupId>org.apache.logging.log4j</groupId> <groupId>org.apache.logging.log4j</groupId>
<artifactId>log4j-slf4j-impl</artifactId> <artifactId>log4j-slf4j-impl</artifactId>
<version>${log4j2.version}</version> <version>${log4j2.version}</version>
<scope>provided</scope> <scope>test</scope>
</dependency> </dependency>
<dependency> <dependency>
<groupId>org.apache.logging.log4j</groupId> <groupId>org.apache.logging.log4j</groupId>
<artifactId>log4j-jcl</artifactId> <artifactId>log4j-jcl</artifactId>
<version>${log4j2.version}</version> <version>${log4j2.version}</version>
<scope>provided</scope> <scope>test</scope>
</dependency> </dependency>
<!-- Apache commons --> <!-- Apache commons -->
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment