Commit a1debfef authored by Matija Obreza's avatar Matija Obreza
Browse files

CI updated

parent 299dbcda
......@@ -5,7 +5,7 @@ run tests in branches:
stage: build
image: maven:3-jdk-8
script:
- MAVEN_OPTS="${MAVEN_OPTS} -Dorg.slf4j.simpleLogger.defaultLogLevel=warn" mvn test -B
- MAVEN_OPTS="${MAVEN_OPTS} -Dorg.slf4j.simpleLogger.defaultLogLevel=warn" mvn test -B -U
except:
- master
- tags
......@@ -13,9 +13,10 @@ run tests in branches:
publish maven snapshot artifacts:
stage: build
image: maven:3-jdk-8
script:
- echo "${GPG_KEY_SECRET}" | gpg --allow-secret-key-import --import
before_script:
- echo "${GPG_KEY_SECRET}" | gpg --batch --import
- gpg --list-keys
script:
- mvn clean deploy --settings .ci-maven-settings.xml -B -U
only:
- master
......@@ -23,9 +24,11 @@ publish maven snapshot artifacts:
publish maven artifacts:
stage: build
image: maven:3-jdk-8
script:
- echo "${GPG_KEY_SECRET}" | gpg --allow-secret-key-import --import
before_script:
- echo "${GPG_KEY_SECRET}" | gpg --batch --import
- gpg --list-keys
- mvn clean deploy --settings .ci-maven-settings.xml -B -U -Prelease
- export GPG_TTY=$(tty) # gpg: signing failed: Inappropriate ioctl for device
script:
- mvn -P release clean deploy --settings .ci-maven-settings.xml -B -U
only:
- tags
- /^geo\-tools\-/
......@@ -65,7 +65,7 @@
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<jdk.target>1.8</jdk.target>
<jdk.source>1.8</jdk.source>
<maven-gpg-plugin.version>1.5</maven-gpg-plugin.version>
<maven-gpg-plugin.version>1.6</maven-gpg-plugin.version>
</properties>
<build>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment