Commit f7e7c579 authored by Matija Obreza's avatar Matija Obreza
Browse files

v1.0.0-alpha6

parent 4691e5d5
......@@ -29,9 +29,13 @@ The demo at https://genesys-pgr.p.gitlab.croptrust.org/ui-embedded/ displays dat
const CLIENTKEY = 'changeme';
const FILTER = { institute: { code: ['ETH013'] } };
genesys.showGenesysUI(APIURL, CLIENTID, CLIENTKEY,
document.getElementById('genesys-container'),
FILTER,
genesys.showGenesysUI(document.getElementById('genesys-container'), {
clientId: CLIENTID,
clientKey: CLIENTKEY,
apiUrl: APIURL,
filter: FILTER,
},
queryLang,
);
</script>
```
......
......@@ -53,8 +53,8 @@
felis nec auctor ultrices.</p>
</div>
<script src="https://cdn.jsdelivr.net/npm/@genesys-pgr/ui-embedded@1.0.0-alpha5/dist/genesys-deps.js"></script>
<script src="https://cdn.jsdelivr.net/npm/@genesys-pgr/ui-embedded@1.0.0-alpha5/dist/genesys-ui.js"></script>
<script src="https://cdn.jsdelivr.net/npm/@genesys-pgr/ui-embedded@1.0.0-alpha6/dist/genesys-deps.js"></script>
<script src="https://cdn.jsdelivr.net/npm/@genesys-pgr/ui-embedded@1.0.0-alpha6/dist/genesys-ui.js"></script>
<script type="text/javascript">
const APIURL = 'https://api.sandbox.genesys-pgr.org';
const CLIENTID = 'TDlQz.LUmnd6YIOtWr4kjnVEFi@api.sandbox.genesys-pgr.org';
......@@ -63,9 +63,12 @@
const queryLang = document.location.search && document.location.search.substr(1) || undefined;
genesys.showGenesysUI(APIURL, CLIENTID, CLIENTKEY,
document.getElementById('genesys-container'),
FILTER,
genesys.showGenesysUI(document.getElementById('genesys-container'), {
clientId: CLIENTID,
clientKey: CLIENTKEY,
apiUrl: APIURL,
filter: FILTER,
},
queryLang,
);
</script>
......
{
"name": "@genesys-pgr/ui-embedded",
"version": "1.0.0-alpha5",
"version": "1.0.0-alpha6",
"publishConfig": {
"access": "public"
},
......@@ -32,11 +32,11 @@
"analyze": "webpack --config config/webpack-analyze.config.js"
},
"dependencies": {
"d3": "^6.2.0",
"es-cookie": "^1.0.0",
"history": "^4.0.0",
"i18next": "^19.0.0",
"react": "^16.0.0",
"d3": "^6.2.0",
"react-dom": "^16.0.0",
"react-i18next": "^11.0.0",
"react-router-dom": "^5.0.0"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment