Commit a8c361a7 authored by Matija Obreza's avatar Matija Obreza
Browse files

Merge branch '15-upgrade-to-j11' into 'master'

Resolve "Upgrade to J11"

Closes #15

See merge request genesys-pgr/validator!15
parents 79c23eab cc79b626
variables:
IMAGE_VERSION: "1.1"
IMAGE_VERSION: "3.0"
DOCKER_HOST: "genesys1.swarm.genesys-pgr.org"
stages:
......@@ -9,7 +9,7 @@ stages:
run tests in branches:
stage: compile
image: maven:3-jdk-8
image: maven:3-openjdk-11
script:
- MAVEN_OPTS="${MAVEN_OPTS} -Dorg.slf4j.simpleLogger.defaultLogLevel=warn" mvn test -B -U
except:
......@@ -18,7 +18,7 @@ run tests in branches:
build:
stage: compile
image: maven:3-jdk-8
image: maven:3-openjdk-11
script:
- MAVEN_OPTS="${MAVEN_OPTS} -Dorg.slf4j.simpleLogger.defaultLogLevel=warn" mvn package -B -U
only:
......
FROM jetty:9.4.27-jre8
FROM jetty:9.4.32-jre11
LABEL maintainer "Matija Obreza <matija.obreza@croptrust.org>"
......
......@@ -6,25 +6,25 @@
<packaging>war</packaging>
<artifactId>validator-web</artifactId>
<name>The Validator</name>
<version>1.1</version>
<version>3.0-SNAPSHOT</version>
<properties>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<jdk.target>1.8</jdk.target>
<jdk.source>1.8</jdk.source>
<jdk.target>11</jdk.target>
<jdk.source>11</jdk.source>
<show.deprecations>true</show.deprecations>
<slf4j.version>1.7.28</slf4j.version>
<slf4j.version>1.7.30</slf4j.version>
<jetty.version>9.4.27.v20200227</jetty.version>
<jetty.version>9.4.32.v20200930</jetty.version>
<jstl.version>1.2</jstl.version>
<servlet-api.version>4.0.1</servlet-api.version>
<spring.framework.version>5.2.4.RELEASE</spring.framework.version>
<spring.framework.version>5.2.12.RELEASE</spring.framework.version>
<commons-lang3.version>3.3.2</commons-lang3.version>
<genesys-geotools.version>1.1</genesys-geotools.version>
<taxonomy-tools.version>1.3</taxonomy-tools.version>
<commons-lang3.version>3.11</commons-lang3.version>
<genesys-geotools.version>3.0-SNAPSHOT</genesys-geotools.version>
<taxonomy-tools.version>3.0-SNAPSHOT</taxonomy-tools.version>
</properties>
<licenses>
......@@ -56,7 +56,7 @@
<connection>https://gitlab.croptrust.org/genesys-pgr/validator.git</connection>
<developerConnection>scm:git:git@gitlab.croptrust.org:genesys-pgr/validator.git</developerConnection>
<url>scm:git:git@gitlab.croptrust.org:genesys-pgr/validator.git</url>
<tag>validator-web-1.1</tag>
<tag>HEAD</tag>
</scm>
<issueManagement>
......@@ -147,7 +147,7 @@
<dependency>
<groupId>com.google.guava</groupId>
<artifactId>guava</artifactId>
<version>19.0</version>
<version>30.1-jre</version>
</dependency>
<dependency>
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment